Das Dienstleistungsangebot des KMSC Dr. Lüpke

Das Dienstleistungsangebot des
Kommunikations-
& [image] Medien-
Service
Chemie
IT- & EDV-Leistungen
© Copyright 2000–2006 Dr. Michael Lüpke, Ostfildern Kontakt


KMSC Dr. Lüpke: Lösungen für IT & EDV in den Life Sciences

IT- & EDV-Leistungen
Konzeption & Realisierung von individuellen Datenbank-Lösungen
Informations- management | VBA | Datenbank- Anwendungen
Kiosksysteme | MS Access | MS Excel
Electronic Books | Visual Basic | Integration in MS Office
MS HTML- Hilfe-Systeme | Online- Dokumentationen | MS Word
+++ Seminare +++ Schulung +++ Training +++ Support +++
© Copyright 2000–2006 Dr. Michael Lüpke, Ostfildern Kontakt Home


KMSC Dr. Lüpke: Modernste Datenbank-Technologie auf Ihren Schreibtisch !

Ausgangspunkt

Holen Sie sich modernste Datenbank-Technologie auf Ihren Schreibtisch ... !

... und profitieren Sie von Vorteilen, die bisher nur den „großen“ Rechnerwelten vorbehalten waren !

Ausgangspunkt:
Die Menge an Informationen nimmt rasant zu; ebenso werden die Informations-Quellen sowie die vermittelnden Medien immer komplexer und diffiziler.

→ Konventionelle und althergebrachte Methoden und Mittel im Umgang mit Informationen laufen zusehends ins Leere.

→ Ohne eine durchgehende Digitalisierung – auch Ihres Informationsbestandes – wird es künftig „nicht mehr gehen“ !

→ Jedes Informationsmanagement auf digitaler Basis bedarf einer Datenbank-Lösung.

→ Die leistungsstärksten, heute marktführenden Datenbanksysteme bedienen sich der sogenannten relationalen Datenbank-Technologie – das sind „Relationale Datenbank-Managementsysteme“ (RDBMS).

→ Das führende RDBMS im Desktop-Bereich ist Microsoft Access.

→ MS Access ist integriert in MS Office – dem meistbenutzten Office-Paket in Wirtschaft, Verwaltung und Wissenschaft.

→ Die Software-Entwicklungsumgebung VBA ermöglicht die Entwicklung individueller Lösungen, sowie die Anpassung und Erweiterung vorhandener Office-Software.

→ MS Access / VBA ist die Basis zum Aufbau Ihres individuellen Informationsmanagements !
Zum Anfang der Seite Zur vorherigen Seite Zur nächsten Seite


KMSC Dr. Lüpke: Nutzen u. Vorzüge von individuellen Datenbank-Anwendungen

Vorzüge u. Nutzen von Datenbanken

Vorzüge u. Nutzen eines Datenbank-gestützten Informationsmanagements


KMSC Dr. Lüpke: Vom Datenbank-Managementsystem zur Datenbank-Anwendung

DBMS zur DB-Anwendung

Vom Datenbank-Managementsystem (DBMS) zur Datenbank-Anwendung

Die Schwierigkeiten bei der Erstellung einer Datenbank-Anwendung liegen zum einen bei der Konzeption und dem Aufbau der notwendigen logischen wie physischen Ablage- und Beziehungsstrukturen für die aufzunehmenden Daten sowie zum anderen im Einrichten der Werkzeuge für einen effizienten Datenzugriff, was letztlich in der Gestaltung einer Benutzeroberfläche mündet.

Dabei muss das Anlegen der Datenstrukturen bestimmten DV-technischen und -theoretischen Vorgaben folgen. Ansonsten würde nicht nur die Rückgewinnung von Informationen aus dem Datenpool lückenhaft bzw. gar fehlerhaft werden, sondern es würde auch der Aufwand für Wartung und Pflege des Datenpools unverhältnismäßig hoch ansteigen. Die Integrität der Daten, die durch das Einrichten einer EDV-gestützten Datenbank gerade erreicht werden soll, wäre so nicht mehr gewährleistet.
Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Fehler und Versäumnisse, die in den Phasen der Konzeption und des Entwurfs gemacht werden, sind später, an der eingerichteten und mit Daten gefüllten Datenbank-Anwendung, nur noch unter hohem Aufwand zu korrigieren! Zudem wird die Unzulänglichkeit einer derart schlecht vorbereiteten Datenbank-Anwendung mit größer werdendem Datenbestand sogar noch zunehmen !

Ebenso erfordert das Bereitstellen von Werkzeugen für den Datenzugriff eine genaue Kenntnis der in der Datenbank-Anwendung implementierten Datenstrukturen und -beziehungen. Darüber hinaus müssen die vom Datenbank-Managementsystem selbst nur in einer pauschalen Art und Weise bereit gestellten Zugriffswerkzeuge – aufgrund deren komplexer Funktionalität – erst auf ein überschaubares Maß zusammengefasst bzw. selektiert werden und müssen zu einfachen, vom Anwender möglichst intuitiv begreifbaren Werkzeugen aufbereitet werden (GUI, graphische Benutzeroberfläche). Erst danach stehen sie dem Anwender für eine effiziente Nutzung der Datenbank-Applikation zur Verfügung.

Gerade hinsichtlich der effizienteren Nutzung einer Datenbank durch den „normalen“ Anwender ist eine Anpassung der Datenzugriffswerkzeuge an die spezifischen Erfordernisse der jeweiligen Datenbank-Applikation notwendig. Unter Berücksichtigung des gegebenen Datenkontextes sind die Zugriffswerkzeuge an den Anwendungszweck der einzelnen Datenbank sowie vor allem auch an deren spezifische Datenstruktur anzupassen. Dies ist stets mit Programmieraufwand verbunden (in der Regel mit recht erheblichem) und ist nur von einem Experten zu bewerkstelligen !
Zum Anfang der Seite Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Die marktführenden Softwarehersteller versuchen zunehmend, diesen – den normalen Anwender total überfordernden – Ansprüchen dadurch zu begegnen, dass sie ihre Datenbank-Programme unter Beigabe von Datenbank-Schablonen sowie von sogenannten Assistenten ausliefern.

Die Datenbank-Schablonen sind eine Art Musterlösung für ganz bestimmte Anwendungszwecke, die vom Anwender nur noch mit Daten gefüllt zu werden brauchen. Allerdings sind sie als Schablonen naturgemäß standardisiert und können somit individuellen Ansprüchen und Erfordernissen nur ungenügend entsprechen. Der Anwender kann sie zwar mehr oder weniger anpassen, aber er braucht dann auch dazu wiederum die Kenntnis, was er wo und wie programmiertechnisch realisieren kann – d.h. auch hierzu ist letztlich wieder ein Experte gefordert !

Die Assistenten führen den Anwender menügesteuert durch die wesentlichen Stationen der Entwicklung einer Datenbank-Anwendung. Solche Assistenten leiden allerdings ebenfalls – wie die Schablonen – unter ihrer (naturgemäßen) Standardisierung. Und sie liefern im Ergebnis zudem nur äußerst einfach strukturierte Datenbanken, mit denen komplexere Anforderungen nicht abzubilden sind. Im übrigen genügen sie auch nicht den schon erwähnten Datenbank-theoretischen Erfordernissen.
Zum Anfang der Seite Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Die ausgeführten Zusammenhänge machen deutlich, weshalb Datenbank-Programme im PC-Sektor bisher keine allzu große Verbreitung gefunden haben. – Im Gegensatz zum Midrange- oder gar Mainframe-Bereich, wo Datenbank-Managementsysteme wie Oracle oder DB2 seit vielen Jahren eine starke Durchdringung des Marktes aufweisen (allerdings mit einem für den PC-Bereich kaum denkbaren Bedienungs- und Wartungsaufwand).

Hinsichtlich der „Verbreitung“ von PC-Datenbank-Programmen darf man sich übrigens nicht von der Statistik der reinen Verkaufs- und Installationszahlen täuschen lassen: Datenbank-Programme werden, wie schon ausgeführt, im PC-Bereich häufig im Bundle mit anderen Programmen vertrieben, d.h. als Bestandteil von Office-Paketen. Und es kann somit eben nicht davon ausgegangen werden, dass ein installiertes Datenbank-Programm (hier im Sinne von Datenbank-Managementsystem) auch tatsächlich zu einer Datenbank-Anwendung beim Nutzer führt.

Somit ist schließlich auch die aktuell von den marktbeherrschenden Softwareherstellern praktizierte Strategie nachvollziehbar, das Datenbank-Programm aus ihrem (Standard-)Office-Paket auszugliedern und es getrennt von diesem (wie bei Corel Paradox) bzw. in einer speziellen Professional-Version des Office-Pakets (wie bei MS Access) zu vertreiben.


KMSC Dr. Lüpke: Nutzen u. Vorzüge gerade von MS Access als Ihrer Datenbank-Plattform

Das spricht für MS Access !

Nutzen u. Vorzüge gerade von MS Access als Ihrer Datenbank-Plattform

  • Desktop-System (PC-gestützt)
  • Windows-Betriebssystem(e)
  • extrem leistungsstark
  • umfangreiche Funktionalität
  • ausgereifte u. bewährte Software-Technologie
  • weitreichende Programmierbarkeit (VBA)
  • (relativ) leichte Beherrschbarkeit
  • gewohnte Software-Umgebung (GUI, Benutzerführung)
  • Integration in MS Office

Wozu Ihnen individuelle Desktop-Datenbanken nützlich sind

  • modernes Informationsmanagement in Ihrer Hand und unter Ihrer Kontrolle
  • keine „Fremdbestimmung“ (wie bei Großrechner- und Netzwerk-Systemen)
  • strukturierte, vollständige, konsistente und damit sichere Datenhaltung
  • schnelle, flexible und effiziente Datenverarbeitung
  • Individual-Lösung heißt:
    spezifisch abgestimmt auf Ihre Erfordernisse, Ansprüche u. Wünsche
  • jederzeit individuell anpassbar und erweiterbar
  • integriert in bzw. angepasst an Ihre gewohnte Arbeitsumgebung

Was der KMSC Dr. Lüpke diesbezüglich für Sie tun kann

  • Beratung hinsichtlich der Möglichkeiten und Machbarkeiten – einschließlich zugehöriger Aufwandsschätzungen
  • Konzeption von Lösungen – individuell u. spezifisch
  • Realisierung / EDV-technische Umsetzung der Konzepte
  • Seminare, Schulung, Training und Support

Phasen der Ausarbeitung einer individuellen Datenbank-Lösung für Sie – ein Überblick


KMSC Dr. Lüpke: Nutzen und Vorzüge der Kombination MS Access & VBA

MS Access & VBA

Was spricht für die Kombination gerade von MS Access & VBA ?

Nahezu jedes EDV-gestützte Informationsmanagement basiert in seiner softwaretechnischen Realisierung auf einer Datenbank-Lösung. Nur mit Hilfe der physischen und logischen Strukturen einer Datenbank ist eine

  • strukturierte, vollständige und konsistente Datenhaltung

möglich. Ebenso bedürfen ein

  • effizientes Information-Retrieval

sowie zumeist auch das Aus- und Bewerten von Informationen des vorherigen (wenn vielleicht auch nur intermediären) Ablegens der Daten in einer Datenbank.
Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Die Notwendigkeit zu einem

  • EDV-gestützten Informationsmanagement

nimmt in so gut wie allen Berufszweigen rapide an Bedeutung zu. Denn nicht nur die Menge an Informationen erfährt geradezu eine exponentielle Steigerung, sondern es nehmen auch deren Vielfalt und Komplexität deutlich zu.
Gleichzeitig wird der in der modernen Gesellschaft vorhandene Drang zur Individualisierung (man denke an PC’s, Pkw’s, Single-Haushalte etc.) wohl dazu führen, dass der Grad des aus der Informationsverarbeitung zu ziehenden Nutzens künftig verstärkt gerade in der Verantwortung des Einzelnen liegen wird.
Zum Anfang der Seite Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Unter dem Betriebssystem MS Windows®, und somit im Bereich der PC’s, ist MS Access spätestens seit der Version 97 (8.0) das marktführende Datenbank-Entwicklungssystem; und es ist bestens zur Ausarbeitung gerade von individuellen Datenbank-Anwendungen geeignet.
(Das zu DOS-Zeiten den Markt noch dominierende dBase hat den Sprung in die Windows-Welt nie so richtig geschafft ...)

Der seit Jahren zunehmende und dabei immer geschäftsmäßiger werdende Einsatz von MS Access gipfelt zur Zeit in einem schier explodierenden Angebot an entsprechender Fachliteratur, einer drastischen Ausweitung des zugehörigen Seminar- und Schulungsangebotes sowie einer deutlich gestiegenen Nachfrage von MS Access-spezifischem Know-how auf dem Arbeitsmarkt.

Für die breite Akzeptanz der mit MS Access erstellten Datenbank-Anwendungen sehr vorteilhaft ist die Integration von MS Access selbst, wie auch der damit erstellten Anwendungen, in die Office-Software von Microsoft (im PC-Bereich das marktführende unter den Office-Paketen).

Nicht zuletzt hängt die Marktdominanz von MS Access mit dem nunmehr darin – wie auch in den anderen MS Office-Programmen – integrierten Programmierwerkzeug VBA, Visual Basic for Applications, zusammen.
Zum Anfang der Seite Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

VBA ist seit der Version MS Office 97 das Office-weit integrierte Programmiertool von Microsoft. Für die Bedeutung von VBA spricht, dass es mittlerweile von einer Reihe Softwarehersteller, und gerade auch von direkten Wettbewerbern von Microsoft, für deren Produkte lizenziert worden ist; so beispielsweise von Corel für die Grafik-Suite und das Office-Paket.

Für die Entwicklung von Individual-Anwendungen in der Umgebung etablierter Office-Software ist VBA zur Zeit unter Windows-Betriebssystemen das am meisten verbreitete Programmiertool – und das mit steigender Tendenz.

Der große Vorteil von VBA gegenüber klassischen Programmiersprachen wie C/C++ oder Object Pascal (Delphi) ist eben gerade diese Einbindung in ausgereifte, leistungsstarke und weit verbreitete Standard-Software.
VBA kann auf die „Objekte“ (die softwaretechnologischen Bestandteile) von MS Office direkt zugreifen. Das macht die Entwicklung von Anwendungen hinsichtlich des Zeit- und Programmieraufwandes sehr effizient und ist nicht zuletzt softwaretechnisch auch sehr zuverlässig.
Und der Zugriff auf die Objekte ist gleichbedeutend mit der Nutzbarmachung der enormen Funktionsvielfalt der Office-Komponenten (neben Access vor allem Word und Excel, aber auch Outlook) für die eigenen Individual-Applikationen.

Übrigens sind die mit MS Access und VBA entwickelten Anwendungen nicht nur auf eine Verwendung innerhalb „ihrer“ Office-Software beschränkt. Sie sind, nach kleineren technischen Anpassungen während der Ausarbeitung, problemlos auch eigenständig (standalone) lauffähig, d.h. auf Systemen ohne installiertes MS Access bzw. gar MS Office.


KMSC Dr. Lüpke: Angebot an IT- & EDV-Leistungen für die Life Sciences

IT- & EDV-Dienstleistungen

Das können Sie vom KMSC Dr. Lüpke erwarten ...

Datenhaltung u. Datensicherheit

  • Professionelle Anlage von Datenstruktur und Datenbeziehungen – gemäß dem Relationalen Datenbank-Modell
  • Sorgfältige und vor allem korrekte Festlegung von Primär- und Fremdschlüsseln sowie der Feld-Datentypen
  • Implementierung von Referentieller Integrität – unabdingbar zur Wahrung der Datenkonsistenz
  • Eingabekontrollen und Tests auf Plausibilität
  • Prüfung auf Stimmigkeit und Vollständigkeit
  • Trennung der beiden Arbeitsmodi „Recherchieren“ und „Bearbeiten“ – Schreibschutz im Modus „Recherchieren“
Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Aus- u. Verwertung der Daten / Funktionalität

  • Effiziente Tools zum Information-Retrieval
  • Präzise, schnelle und vollständige sowie zudem noch komfortable Rückgewinnung von Informationen aus dem Datenpool
  • Einsatz von SQL – der universellen Datenbank-Abfrage- und Manipulationssprache
  • Funktionalität in Umfang und Art individuell abgestimmt auf Ihren Bedarf und Ihre Wünsche
  • Rationelles Arbeiten – da keine verwirrende Menü-Vielfalt und kein unnötiger „Funktions-Ballast“
  • Per Hyperlink-Technik Verknüpfungen zu beliebigen Dokumenten, Dateien oder URL’s
  • Vielfältige Möglichkeiten des Imports und Exports von Daten – Nutzung diverser Datenformat-Filter
  • Datenaustausch mit anderen (Office-)Anwendungen
  • Individuelle und spezifische Report-Erstellung
Zum Anfang der Seite Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Auch hierauf sollten Sie nicht verzichten ...

Benutzerführung u. Oberfläche

  • Graphische Benutzeroberfläche (GUI) in MS Windows-konformer Gestaltung
  • Hoher Bedienkomfort durch den Einsatz bekannter GUI-Elemente und Anwendung gewohnter Benutzerführungen
  • Reduzierung der Anzahl GUI-Elemente auf das für Ihre Anwendung notwendige Maß – schnelles Zurechtfinden, kurze Einarbeitung
  • Leistungsstark in Technologie und Funktionalität – und dennoch leicht verständlich in der Handhabung

Online-Hilfe-System

  • In Umfang, Inhalt u. Stil maßgeschneidert für Ihre Erfordernisse und Gewohnheiten
  • Abdeckung genau Ihres individuellen Informationsbedarfs – mit spezifischen Inhalten und in kurzer, prägnanter u. verständlicher Formulierung
  • Selbstverständlich kontextsensitiv

Integration in / Kompatibilität mit Microsoft Office

  • Einbindung der Objekte und der Funktionalität der MS Office-Anwendungen (MS Word, MS Excel etc.) – dadurch Zugriff auf extrem umfangreiche und bewährte Funktionalität
  • Ausarbeitung Ihrer Anwendung auch als Standalone-Produkt – für Systeme ohne installiertes MS Access


KMSC Dr. Lüpke: Phasen, Einteilung und Ablauf Ihres EDV-Projektes

Phasen Ihres EDV-Projektes

Datenbank-Projekte

Projekte zur Konzeption & Realisierung von individuellen Datenbank-Lösungen verlangen stets eine ausgesprochen gründliche Vorbereitung und erfordern auch im Verlaufe des Projektes einen ständigen Austausch mit Ihnen als Auftraggeber. Zudem zeichnen sie sich im allgemeinen auch durch eine Nach-Projekt-Betreuung aus.
Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite

Bei der Abwicklung solcher Projekte sind folgende „Phasen“ oder auch „Module“ zu unterscheiden :

  1. Analyse
    • Anforderungsprofil
    • Informationsbedarf
    • Absicht u. Ziel
  2. Konzeption
    • Möglichkeiten
    • Machbarkeiten
    • Grobentwurf
    • Aufwandsabschätzung
  3. Pflichtenheft
    • Detailentwurf
    • Spezifikation
    • Aufwandsfestlegung
  4. Entwurf u. Design
    • Datenstrukturen u. Datenbeziehungen
    • Funktionalität, Benutzerführung
    • Abfragen, Berichte, Unterstützung
    • Benutzeroberfläche (GUI), Menüs
  5. Realisierung
    • Programmierung, Implementierung
    • Test, Verifizierung
    • Dokumentation, Online-Hilfe
  6. Schulung u. Support
    • Tutorien, Seminare, Training
    • Hotline, Infoline
    • Änderungen, Anpassungen, Erweiterungen

Die einzelnen Module sind in sich geschlossene Einheiten und sind als solche im Grunde unabhängig voneinander zu bearbeiten. Das hat für Sie als Auftraggeber die Vorteile, dass

  • jedes einzelne Modul in der Regel gesondert honoriert wird und
  • das Projekt einer stufenweisen Erfolgskontrolle zugänglich ist.


KMSC Dr. Lüpke: Kontaktdaten & Kurzporträt

Kontaktdaten & Kurzporträt

Der KMSC Dr. Lüpke, Kommunikations- & Medien-Service Chemie, ist ein im Raum Stuttgart ansässiges Servicebüro zur Ausarbeitung von Datenbank-gestützten Softwaretools für ein effizienteres individuelles Informationsmanagement im wissenschaftlich-fachlichen Umfeld der Life Sciences.
Darüber hinaus bietet er in diesem Rahmen die Recherche, Aus- und Bewertung, Präsentation und Dokumentation von Daten, Fakten und Hintergründen an.

Inhaltlich-fachlich hat der KMSC Dr. Lüpke seine Schwerpunkte bei der Vermittlung von lebensmittelwissenschaftlichen Zusammenhängen sowie von Informationen um Ursache, Bedeutung und Wirkung von solchen chemischen und biologischen Prozessen, die einen Bezug zum Individualkontext von Konsumenten und Verbrauchern haben.

Zum Ende der Seite Zur vorherigen Seite Zur nächsten Seite
Der KMSC Dr. Lüpke ist ein Servicebüro von:

Dr. Michael Lüpke

Lebensmittelchemiker, Dr. rer. nat., staatl. gepr.
Anwendungsinformatiker – Wirtschaft (VWA)

Anschrift:

 | Dr. Michael Lüpke
 | KMSC Dr. Lüpke
 | Ulmenweg 10
 | D-73760 Ostfildern
Tel./Fax: | (+49) (0)711 / 6993173
E-Mail: | kmsc@dr-luepke.de
Home: | http://www.dr-luepke.de

Copyright

Sämtliche Inhalte dieses Dokumentes, einschließlich der grafischen und bildlichen Darstellungen, sind urheberrechtlich geschützt. Ihre Verwendung und insbesondere ihre Weiterverbreitung sind ohne ausdrückliche, schriftliche Genehmigung des KMSC Dr. Lüpke nicht gestattet !
Zum Anfang der Seite Zur vorherigen Seite Zur nächsten Seite
© Copyright 2000–2006 Dr. Michael Lüpke, Ostfildern Home